The Tech Explorations Forums

Find answers, ask questions, and connect with our
community around the world.

Home Forums ESP32 for Busy People (Forum) CP210x Windows VCP Driver Problem

Tagged: ,

  • CP210x Windows VCP Driver Problem

  • paul.seidel.cg@gmail.com

    Member
    July 9, 2019 at 2:13 pm

    I am running windows 8.1 on the machine I am using and followed instructions to download the Scilabs driver for version 6.7.6 (Windows 7/8/8.1). I unzipped, ran the installer application for my 64-bit machine, and restarted the OS, then the Arduino IDE (which I just updated to the latest version). The IDE shows “None on COM4” for board information on the bottom, but the Port remains unrecognized under the tools menu.

    Could it be my micro USB cable is of the charge only type?
    Has anyone else had this problem?

    Thanks,
    Paul

  • Peter Dalmaris

    Administrator
    July 10, 2019 at 1:57 pm

    Hi Paul,

    to begin the troubleshooting process, let’s rule out a problem with the cable you are using.

    Can you use this cable with another USB device successfully?

    If you are confident that the cable is working ok, please use the Device Manager to confirm that the OS can actually see the device.

    For Windows 8, you can follow the instructions here (this is a Microsoft support page).

    Can you see your ESP32 in the device manager?

  • paul.seidel.cg@gmail.com

    Member
    July 12, 2019 at 1:46 pm

    Peter and Lina, I replaced the cable with a known good data cable, and everything works great now. Moving right on to the good stuff. Thanks, and looking forward to the rest of it.

  • Peter Dalmaris

    Administrator
    July 14, 2019 at 11:56 am

    Ah, that’s great, thank you for confirming it was a cable issue.

Log in to reply.

Original Post
0 of 0 posts June 2018
Now
>